Script Troubleshooting Help Please

Eorzea Time
 
 
 
言語: JP EN FR DE
日本語版のFFXIVPRO利用したい場合は、上記の"JP"を設定して、又はjp.ffxivpro.comを直接に利用してもいいです
499 users online
フォーラム » Windower » Spellcast Scripting » Other » Script Troubleshooting Help Please
Script Troubleshooting Help Please
Offline
Posts: 2
By Fingolfin 2013-06-09 16:30:35  
I was in the process of tweaking the Xilk BST spellcast to make it a little simpler for my purposes and after quite a bit of editing, I realized it wasn't performing its most basic function (equipping my gearsets when engaged/idle). Also having issues equipping pet food for reward and/or jug pet for Callbeast, it just doesn't seem to recognize the command.

I think this has something to do with my attempting to use variables to define various things. I.e. gear sets for idle/engaged as well as pet food and jugs.

I was attempting to copy what Xilk had done for ready moves, but obviously I went wrong somewhere along the way and can't really determine where.

Any chance someone could have a look and let me know where I'm going astray?

http://pastebin.com/mXqR4BKG

Thanks in advance.
Offline
Posts: 2
By Fingolfin 2013-06-09 18:46:12  
Figured it out, for some reason not having a group tag in the sets was causing problems in the rest of the file, appears to work now.

On a somewhat related note, if someone else uses Xilk's ready.cycle for purposes of selecting ready moves on called pets, I'd be interest to hear if anyone has run into (or even better, managed to fix) the issues that, once you go from one pet to another, the ready.cycle gets stuck as the first move of the first pet you had summoned.

For example, I have FlowerpotMerle out, I hit leave, I call LuckyLulush, and hit the ready.cycle and all I keep getting is "Leaf Dagger".

Haven't been able to troubleshoot this either, been reloading the script to fix it everytime I call a new pet.

Anyone have a better fix?